上一篇 下一篇 分享链接 返回 返回顶部

OpenSSH高危远程代码执行漏洞曝光,超过1400万台服务器面临威胁

发布人:千 发布时间:2024-07-02 11:12 阅读量:111

网络安全公司 Qualys 威胁研究团队日前公布了 OpenSSH 中的高危远程代码执行漏洞,该漏洞编号为 CVE-2024-6387,扫描显示暴露在公网上的受影响的服务器超过 1400 万台。

该漏洞广泛影响安装 OpenSSH 的各种 Linux 服务器,而类 UNIX 系统 FreeBSD 在 2001 年开发了一种可以防止此漏洞的安全机制,因此该系统不受影响。

值得注意的是此漏洞曾经出现过但在 2006 年被修复,在 2020 年发布的 OpenSSH 新版本中又重新出现了,所以受影响的 OpenSSH 版本略微有些复杂,具体可以参考下面的说明。

OpenSSH出现高危远程代码执行漏洞 影响超过1400万台暴露在公网上的服务器

受影响的 OpenSSH 版本:

  • 低于 4.4p1 版 (不含此版本):受影响
  • 高于 4.4p1 但低于 8.5p1 (不含此版本):不受影响
  • 8.5p1 及后续版本到 9.8p1 (不含此版本):受影响

考虑到 8.5p1 及之前的版本已经非常老旧估计使用量比较低,因此这里可以直接以 8.5p1 版作为分水岭,若系统使用的 OpenSSH 版本为 9.8p1 以下版本那就受到影响,用户应当尽快更新到 9.8p1 及后续版本。

该漏洞的潜在影响:

攻击者利用此漏洞实际上可以以最高权限执行任意代码,因此一旦得手就可以获得整个系统和服务器的控制权,无论是安装恶意软件还是窃取数据都是轻轻松松完成。

同时 Qualys 还提到攻击者还可以借助此漏洞获得的权限绕过防火墙、入侵监测系统和日志记录机制等关键安全机制,即可以通过这些方式避免被发现并隐藏其活动。

发起攻击的难度:

然而由于该漏洞具有远程竞争条件特性,因此实际利用的话也有难度,攻击者可能需要尝试很多次才可以成功攻击,这会导致内存损坏并且要克服地址空间布局随机化 (ASLR)。

基于以上问题有能力的攻击者可以利用深度学习技术提高漏洞利用率,所以对用户、开发者、企业来说应当尽快检查更新获取 OpenSSH 最新版。

目前已经有部分 Linux 系统开发商推出安全更新修复这一漏洞,如果用户尚未检查到更新请换个时候再次检查更新,尽可能第一时间修复此漏洞。

目录结构
全文